Tampilkan postingan dengan label slackware. Tampilkan semua postingan
Tampilkan postingan dengan label slackware. Tampilkan semua postingan

Konfigurasi DNS Server pada Slackware

Assalamualaikum.
Hari ini saya akan sedikit sharing tentang slackware lagi, mumpung ada lagi waktu buat ngeblog lagi hehehe
Kali ini saya akan share tentang Konfigurasi DNS Server pada Slackware. Ya ya ya, DNS Server.
Sebenarnya apa DNS Server itu?
DNS itu kepanjangannya, Domain Name System yang dimana mengubah nama IP menjadi nama domain. Jadi lebih memudahkan kehidupan manusia sehari-hari, terutama mengakses komputer. Kalau gak ada DNS Server, otomatis kalau mau buka facebook, alamat yang kita ketik di browser itu alamat IP dari komputer server facebook.
Oke kalau sudah paham, kita lanjut ke percobaan kecil kita. Membuat dns server dengan Slackware bukan?
Ya. Untuk konfigurasi dns server, pertama kita harus menginstall bind9 pada Slackware ktia, tapi kalau gak salah sih Slackware sudah tersedia bind9 sejak awal hehehe, jadi gak usah di jelaskan tahap disini.

Kali ini, saya memiliki alamat IP 192.168.0.1 dan ingin menamainya imammashur.co.id

Oke, pertama kita mengedit file /etc/named.conf
# nano /etc/named.conf
edit menjadi kurang lebih seperti ini

options {
        listen-on port 53 {127.0.0.1; 192.168.0.0/24;};
        directory "/var/named/caching-example/";
        allow-query { localhost; 192.168.0.0/24;};
};

zone "." IN {
        type hint;
        file "named.ca";
};

# Baris dns-ku
zone "imammashur.co.id" IN {
        type master;
        file "/var/named/caching-example/named.local";
        allow-update { none; };
};

#Reverse Zone
zone "0.168.192.in-addr.arpa" IN {
        type master;
        file "/var/named/caching-example/db.192.168.0";
        allow-update {none; };
};

Kemudian, kita edit file yang harus kita configurasi diatas, yaitu named.local, dan db.192.168.0, padahal file db.192.168.0 itu gak ada bukan? hehehe

Kita ganti nama dari localhost menjadi db.192.168.0
mv /var/named/caching-example/localhost.zone /var/named/caching-example/db.192.168.0

Kemudian, kita edit file dari named.local dan file dari db.192.168.0 itu, isinya seperti ini
nano /var/named/caching-example/named.local
isi file named.local
$TTL    86400
@       IN      SOA     imammashur.co.id. root.imammashur.  (
                                      2011032500 ; Serial
                                      28800      ; Refresh
                                      14400      ; Retry
                                      3600000    ; Expire
                                      86400 )    ; Minimum
@       IN      NS      imammashur.co.id.
@    IN    A    192.168.0.1
nsl     IN      A       192.168.0.1
@    IN    MX  10  mail.imammashur.co.id.
mail    IN    A    192.168.0.2
www    IN    A    192.168.0.1
pc1    IN    A    192.168.0.3
server    IN    A    192.168.0.4

nano /var/named/caching-example/db.192.168.0
isi file db.192.168.0
$TTL    86400
@       IN      SOA     imammashur.co.id. root.imammashur.co.id.  (
                                      2011032500 ; Serial
                                      28800      ; Refresh
                                      14400      ; Retry
                                      3600000    ; Expire
                                      86400 )    ; Minimum
;
@    IN    NS    imammashur.co.id.
1    IN    PTR    www.imammashur.co.id
2    IN    PTR    mail.imammashur.co.id   
3    IN    PTR    pc1.imammashur.co.id
4    IN    PTR    server.imammashur.co.id

Setelah itu, edit pengaturan dns anda di /etc/resolv.conf
tambahkan 1 line seperti ini
nameserver 192.168.0.1

Kemudian, edit file /etc/hosts,
nano /etc/hosts
dan tambahkan 1 line seperti ini
192.168.0.1 imammashur.co.id www

Nah, sekarang kita coba nslookup dns kita sendiri ya
nslookup imammashur.co.id

Server:         192.168.0.1
Address:        192.168.0.1#53

Name:  imammashur.co.id
Address: 192.168.0.1

Oke gan, sekian dan terima kasih hehehe
Wassalamualaikum wr.wb.

Install Driver Vga SiS 771/671 pada Slackware

Assalamualaikum,
Hari ini saya kan install tutorial install VGA Silicon Integrated System [SiS] 771/671 pada Slackware. Mungkin dari kita ada yang menggunakan VGA Silicon Integrated System 771/671 ?
Untuk mengetahuinya, buka terminal pada linux anda masukkan perintah lspci

ini hasil output terminal saya ketika memasukkan perintah lspci

bash-4.1# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0b.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
00:0b.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
00:0b.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)


Bisa di lihat pada baris yang saya beri efek bold, itu VGA laptop yang saya gunakan. Tapi untuk memudahkan, bisa di masukkan tambahan pencarian dengan lspci | grep VGA seperti yang saya perlihatkan

bash-4.1# lspci | grep VGA
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Disitu terdapat tulisan jenis VGA yang ada pada komputer/laptop kita masing-masing.

Baik, jika anda menggunakan VGA yang sama dengan laptop yang saya gunakan ini namun fitur dari VGA seperti resolusi belum terpasang dengan baik, mari baca postingan ini.

  1. Download driver vga di Link Ziddu ini
  2. Kemudian extract file yang anda download tadi
  3. Buka terminal dan masuk di lokasi file yang telah anda extract tadi
  4. Copy file sisimedia ke lokasi kumpulan driver dengan perintah cp sisimedia.drv /usr/lib/xorg/modules/drivers/ Jika tidak bisa, anda harus menjadi super user terlebih dahulu
  5. Kemudian copy file xorg.conf ke /etc/X11/xorg.conf.d/ dengan perintah cp xorg.conf /etc/X11/xorg.conf.d/
  6. Kemudian restart komputer anda...
  7. Selesai
Alhamdulillah, saya berhasil menginstall VGA laptop saya dengan cara tersebut, semoga berhasil kawan dan jika ada masalah tolong beritahukan.. Sekian
Wassalamualaikum..

Install geany untuk programming pada slackware

Assalamualaikum
Hari ini saya akan share tutorial menginstall aplikasi geany pada Slackware. Geany ada salah satu aplikasi yang sering di gunakan sebagai editor untuk bahasa pemrograman untuk linux, kalau windows saya nggak tahu. Selama saya menggunakan geany, aplikasi tersebut support dengan bahasa C, C++, Python, dan Java. Saya tidak tahu dengan bahasa lain seperti fortran, pascal, dkk apakah dia support dengan geany atau tidak.
Logo geany seperti gambar diatas, entah apa makna dari logo tersebut.
Untuk menginstall geany,
  1. pertama anda download dulu file SlackBuild dari geany.
  2. Setelah itu, anda extract filenya di suatu folder tersendiri.
  3. Kemudian, download file source untuk geany. Ini File Source yang saya dapat pada SlackBuild.
  4. Kemudian buka terminal pada luar folder tersebut, kemudian berikan hak akses tertinggi pada folder tersebut dengan perintah chmod -R 777 *nama-folder*
  5. Setelah itu, anda masuk ke folder tersebut dengan perintah cd *nama-folder*
  6. Kemudian jalankan file Slackbuild dalam folder tersebut dengan perintah ./geany.SlackBuild
  7. Kemudian, tunggu beberapa detik karena file anda akan di proses menjadi file installer.
  8. Setelah ada pemberitahuan file anda telah selesai di install, copy file tersebut ke lokasi home folder anda dengan perintah seperti ini cp /tmp/SBo/geany-1.22-i486-1_SBo.tgz ~/
  9. Setelah itu, anda install file tersebut dengan perintah installpkg geany-1.22-i486-1_SBo.tgz
  10. Setelah itu tunggu beberapa detik, dan tunggu 2 sampai 3 menit dan coba lihat list aplikasi anda,
  11. Anda telah berhasil melakukan instalasi geany pada Slackware
Mungkin sekian dari saya, bila ada error atau kendala ataupun kesalahan mohon di tanyakan, sekian dari saya
Wassalamualaikum

Bangkitkan proxy server di Slackware

Assalamualaikum wr.wb.
Hari ini, saya akan menjelaskan tentang proxy server, tahap dari instalasi proxy server, hingga konfigurasi utama dari proxy server.
Mula-mula, apa itu proxy server ?
Proxy merupakan salah satu jenis server yang memiliki tugas untuk mengatur dan memanajemen lintas ke luarnya paket menuju ke tempat node yang dituju. Pada proxy itu sendiri, kita bisa memanajemen apa-apa saja yang boleh di lakukan oleh user luar terhadap kita ataupun kita terhadap user luar.
Jadi hanya itu fungsi utama dari proxy ?
Meskipun seperti itu, proxy ini juga bisa digunakan sebagai penangkal dari serangan DoS (Denial of Service). Minimal, jikalau server anda di targetkan untuk menjadi korban DoS. Yang tidak berfungsi hanyalah proxy saja, itupun hanya sebentar. InsyaAllah server utama masih kecil kemungkinan terkenanya serangan DoS atau Ping Flood.
Nah, setelah bahas-bahas sedikit tentang proxy. Ada baiknya jika kita coba-coba menjadikan pc/laptop kita menjadi proxy server itu sendiri. Hari ini saya memberikan informasi cara melakukan instalasi dan konfigurasi proxy server pada slackware.
Software penyedia layanan proxy server yang saya gunakan kali ini adalah squid3.

Mula-mula, download file squid3 tersebut di slackpackages.

# wget "http://repository.slacky.eu/slackware-13.37/network/squid/3.1.14/squid-3.1.14-i486-1sl.txz"


Kemudian install filenya
# installpkg squid-3.1.14-i486-1sl.txz

Setelah itu,buka kembali folder squid anda, dan perhatikan file-file yang ada di dalamnya
# cd etc/squid/
# ls
cachemgr.conf          errorpage.css.default  squid.conf
cachemgr.conf.default  mime.conf              squid.conf.default
errorpage.css          mime.conf.default      squid.conf.documented

Kemudian, anda edit file squid.conf tersebut, terserah anda mau menggunakan nano ataupun vim
# nano squid.conf

Inimerupakan hasil daripada editan yang saya lakukan di squid.conf,
# Recommended minimum configuration:
#
acl manager proto cache_object
acl localhost src 127.0.0.1/32 ::1
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
#acl localnet src 10.0.0.0/8    # RFC1918 possible internal network
#acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
#acl localnet src 192.168.0.0/16        # RFC1918 possible internal network
#acl localnet src fc00::/7       # RFC 4193 local private network range
#acl localnet src fe80::/10      # RFC 4291 link-local (directly plugged) machines
acl localnet src 192.168.1.0/255.255.255.0 
acl blockeddomain dst "/etc/squid/blocked.domains.acl"
http_access deny blockeddomain

acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT

Kemudian, atur port utama yang digunakan dalam proses pengiriman atau penerimaan file. Kita akan menggunakan port 8080, jadi turun kebawah hingga menemukan seperti ini
# Squid normally listens to port 3128
#http_port 3128
#http_port 192.168.1.1:8080
http_port 3128

Kemudian, buat file untuk file-file yang akan di blok dengan nama blocked.domains.acl
dengan cara perintah touch atau nano
# nano blocked.domains.acl
.google.co.id
.yahoo.co.id
.youtube.co.id

Setelah itu, jalankan squid anda dengan memberikan permission dan proses
# chmod 755 /etc/rc.d/rc.squid
# /etc/rc.d/rc.squid restart

Selamat, anda telah berhasil melakukan konfigurasi squid3. Untuk memberikan sifat management / aturan pada squid server bisa dengan cara buka squid.conf dan edit yang seperti ini
# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
#acl localnet src 10.0.0.0/8    # RFC1918 possible internal network
#acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
#acl localnet src 192.168.0.0/16        # RFC1918 possible internal network
#acl localnet src fc00::/7       # RFC 4193 local private network range
#acl localnet src fe80::/10      # RFC 4291 link-local (directly plugged) machines
acl localnet src 192.168.1.0/24       

Mungkin sekian dari saya, jika ada yang kurang jelas mohon di tanyakan.
Wassalamualaikum wr.wb.

Menjadikan komputer sebagai ftp, dan dns server di debian

Assalamualaikum,
Hari ini saya akan menjelaskan bagaimana cara menjadikan satu komputer itu sebagai sebuah ftp server, dan web server. Hal ini tidak hanya memerlukan banyak sekali waktu ataupun tenaga, yang penting niat mau belajar dengan si debian ini.
Pertama kita melakukan terlebih dahulu instalasi paket ftp untuk debian, namun sebelum itu anda harus mengupdate list package yang tersedia dari sumber yang ada di source.list anda.. dengan cara
$ sudo apt-get update
Setelah itu, lakukan instalasi paket ftp, dan web pada debian anda
$ sudo apt-get install vsftpd apache2

Tunggu hingga prosesnya selesai, kemudian mulai konfigurasi vsftpdnya
edit file pada /etc/vsftpd.conf
$ sudo  nano /etc/vsftpd.conf

Cari line kosong pada lokasi file tersebut dan tambahkan
 anonymous_enable=YES
 local_enable=YES
 write_enable=YES
 local_umask=022
 anon_upload_enable=NO
 local_root=/srv/ftp
 anon_mkdir_write_enable=NO
 xferlog_file=/var/log/vsftpd.log
 ftpd_banner=Welcome to SM's FTP service.

kemudian restart vsftpdnya dengan cara
$ sudo service vsftpd restart

Kemudian, lakukan konfigurasi pada web server,
$ sudo nano /var/www/index.html

Editlah sebagus yang anda inginkan, dan disitulah letak file web server anda tersimpan..

Jika sudah, konekkan satu pc ke pc yang anda pakai tadi, kemudian atur ip-nya
1... 2... 3...
buka browser, pilih http://ip_server
jika terbuka sesuai dengan yang anda edit di /var/www/index.html, maka sudah berhasil..

kemudian buka ftp://ip_server
jika terbuka, maka anda berhasil lagi..

Mungkin sekian dari saya, wassalamualaikum wr.wb.

Teamviewer computer remote on linux

Assalamualaikum
Hari ini saya akan memberikan sedikit ilmu pengetahuan tentang computer remote. Sebenarnya apa yang dimaksud remote computer ? Remote computer yah itu deh, mengendalikan computer seseorang dari jarak jauh. Dengan meremote dari jarak jauh, anda bisa melihat segala isi dari media penyimpanan yang teman anda miliki.

Sebenarnya ada banyak aplikasi yang bisa kita gunakan untuk melakukan remote access desktop. Ada beberapa layanan yang telah disediakan oleh para inventor-inventor teknologi masakini.
Seperti VNC viewer, teamviewer, bahkan hanya dengan modal internetpun sudah bisa lakukan tanpa aplikasi. Yang hanya membutuhkan modal internet ialah seperti, telnet, ataupun ssh remote. Namun kali ini saya hanya akan menjelaskan tentang teamviewer untuk linux.
Teamviewer merupakan salah satu aplikasi yang sangat berguna dalam melakukan remote access ke komputer lain, dengan syarat computer lain menerima remote anda. Teamviewer dapat dijalankan di os dengan kernel apapun, baik itu windows me-remote linux, ataupun sebaliknya. Bahkan sesamanya juga apalagi.
Untuk mendownloadnya silahkan buka
Situs asli teamviewer
Kemudian pilih jenis os yang anda gunakan, setelah itu gunakan

Untuk pengguna linux turunan debian, ubuntu, dsb.
Silahkan di download sesuai system anda, x32 bit atau x64 bit

sebelum itu, anda disarankan untuk mendownload wine. karena biasanya error tanpa wine, install wine dengan cara
$sudo apt-get update
$sudo apt-get install wine

Kemudian download buka terminal, pergi ke lokasi download anda (defaultnya di ~/Downloads/)
$cd ~/Downloads/


kemudian install aplikasinya dengan cara
Untuk x32
$sudo dpkg -i teamviewer_linux.deb
Untuk x64
$sudo dpkg -i teamviewer_linux_x64.deb

Setelah itu, anda disarankan mengaktifkan daemon untuk teamviewer
$sudo teamviewer --daemon starat

Jika telah selesai, maka anda berhasil menginstalasi teamviewer, sekarang anda bisa menggunakannya
$teamviewer

Untuk pengguna slackware

pertama, anda harus download dulu filenya dengan cara
$wget "http://download.teamviewer.com/download/teamviewer_linux.tar.gz"

kemudian jalankan file instalasinya dengan cara
$sudo installpkg teanviewer_linux.tar.gz

setelah itu, jalankan daemon untuk teamviewer anda
$sudo --daemon start

jalankan teamviewer anda
$teamviewer

Mungkin sekian dari saya, semoga bermanfaat.
Wassalamualaikum

Menjadikan sebuah pc menjadi pc router

Assalamualaikum
Hari ini saya akan menjelaskan tentang cara menjadikan sebuah pc biasa menjadi sebuah pc router.
Apa itu Pc Router ? Apa itu router ? Mari biar saya jelaskan satu persatu.
Router merupakan sebuah alat yang digunakan untuk menghubungkan 2 atau lebih jaringan komputer yang ada. Jadi kita bisa mengfungsikan pc yang kita miliki menjadi sebuah router sederhana yang cukup, bahkan sangat bermanfaat. Asalkan punya bahan-bahannya :

Sebuah pc untuk jadi pc router
pc lain untuk menjadi client
Ethernet (nic) card 2 buah
kabel utp cross dan kabel utp straight
Os linux slackware
koneksi internet
hub kalau ingin lebih dari 1 client
persiapkan terminal linux kalian

masuk ke dalam terminal dengan bersiap-siap mengetik
Pertama, adalah kita ketahui bahwa ip dari modem adsl itu ialah 192.168.1.1 berarti kita setting ip address dari nic yang menuju ke modem itu 192.168.1.2
ketikkan
$sudo ifconfig eth0 192.168.1.2/24

Kedua, setting ip nic yang menuju ke hub atau langsung ke client sebagai 192.168.2.1, sehingga ip client itu 192.168.2.x yang dimana x itu lebih dari 1 karena takutnya nanti ip conflict dengan nic di pc router
ketikkan di calon pc router
$sudo ifconfig eth1 192.168.2.1/24

konfigurasi sesuai OS clientnya sebagai berikut :
Ip address = 192.168.2.2/24
gateway = 192.168.2.1

Ketiga, atur alamat gateway di pc router itu agar bisa mengetahui alamat yang akan membawa paket ke sumber internet yaitu alamat ip modem, dengan cara
ketikkan
$sudo route add default gateway 192.168.1.1

Setting juga alamat gateway dari client itu sendiri yaitu 192.168.2.1

ke empat, setting alamat dns untuk server agar bisa mengetahui nama domain-domain yang ada di internet, edit file resolv.conf yang ada di lokasi /etc/resolv.conf
ketikkan
$sudo nano /etc/resolv.conf
hapus semua yang ada di dalamnya kemudian ubah seperti ini
nameserver 202.134.1.10
nameserver 8.8.8.8

Jangan lupa juga untuk mengatur ip dns yang ada di client, untuk menjaga-jaga pengenalan domain client terhadap internet

terakhir, aktifkan fasilitas pc router masquerading yang telah anda siapkan dari tadi melalui terminal.
ketikkan
$sudo echo "1" > /proc/sys/net/ipv4/ip_forward
$sudo iptables -t nat -A POSTROUTING -j MASQUERADE

jika selesai, cobalah ping alamat internet dari client, jika berhasil maka saya ucapkan alhamdulillah dan selamat,
Sekian dari saya
Wassalamualaiku wr.wb.

Slackware - Linux for the geek

Assalamualaikum..
Pada hari ini saya mau memberikan postingan mengenai salah satu linux yang saya gunakan selain ubuntu, saya baru saja pindah linux karena adanya tugas sekolah. Namun setelah mengelilingi isi-isi dari slackware ini, ternyata linux ini "Lumayan Sulit" bagi saya, namun hal itu sangat menyenangkan bagi saya. Karena untuk menyelesaikan masalahnya, sangat sulit di search di internet karena penggunanya belum melonjak penuh seperti ubuntu, jadinya melakukan percobaan sana sini.
Slackware merupakan Operating System yang menggunakan kernel atau inti utama dari operating system berbass Linux atau Unix-like. Slackware sendiri dibuat oleh Patrick Volkedring yang sekarang ini menjadi pemilik Slackware Linux Inc. Diantara distro linux lainnya, slackwarelah distro yang paling mendekati dengan linux original buatan Linuz Torvalds.
Slackware pada awalnya merupakan turunan dari Softlanding Linux System, yang paling populer dari distribusi Linux asli. SLS mendominasi pasar sampai para pengembang membuat keputusan untuk mengganti format executable-nya dari a.out ke ELF. Ini bukan keputusan yang populer di kalangan basis pengguna SLS pada saat itu. Patrick Volkerding meluncurkan versi modifikasi dari SLS, yang dia beri nama Slackware. Rilis pertama Slackware, 1.00, diluncurkan pada tanggal 16 Juli 1993. Berupa sebuah citra 3½ floppy disk yang tersedia melalui FTP.

Sistem manajemen paket Slackware dapat menginstal, dan menghapus paket dari sumber lokal, tetapi tidak akan mencoba untuk melacak atau mengelola dependensi, pengguna harus memastikan sendiri bahwa sistem telah memiliki semua perpustakaan sistem dan program-program yang dibutuhkan oleh paket baru (yang akan diinstal).

Jadi, ingin mencoba linux slackware ? Linux asli di gunakan untuk mempelajari kernel utama dari linux sendiri lohh :)